Android ICS 4.0.3 para wetab (SPANISH) (ACTUALIZADO)

VERSION DEFINITIVA (11-4-2012):

Bueno, esta va a ser posiblemente la ultima version que voy a sacar para esta tablet, por lo menos hasta que el tema de soporte de aplicaciones para x86 por parte de android no este mas desarrollado e Intel no se meta mas en el tema de los drivers.

Creo que quitando un par de cosas la tablet es perfectamente usable con Android, por lo que lo unico que he hecho en esta ultima rom ha sido poner un launcher nuevo que permite cambiar los fondos de escritorio y meter dos ficheros nuevos que posiblemente solucionen el problema del 3G.

Para aquellos que teniais la version anterior instalada, como los cambios son pocos os pongo los ficheros nuevos. El 3gfix.zip se tiene que descomprimir en /system/etc/ppp y el apk solo hay que instalarlo, y cuando le deis a home, seleccionar el nuevo launcher.

Todos los ficheros estan en esta carpeta: Aqui

ACTUALIZACION5 (30-3-2012):
Nueva version con el problema de suspension arreglado, el 3G actualizado y la sd ya funciona correctamente (ver nota despues).
Por favor, que alguien pruebe con una tarjeta de vodafone o movistar o cualquiera que no use roaming como Simyo y pegue en los comentarios si funciona.

En Ajustes almacenamiento se ven solo dos dispositivos, la memoria interna y el usb si teneis un pincho montado. Si meteis una sd real la monta en /mnt/sdcard_ext y podeis acceder a ella con cualquier gestor de ficheros.

Link: Link

ACTUALIZACION4 (8-3-2012):

Ha pasado mas de un mes desde la ultima actualizacion, es lo que hay cuando no me pagan por esto, que solo puedo usar el tiempo del que dispongo..😦

Por cierto, para los que no lo sepais, tengo una cuenta de paypal para donaciones. Si te gusta mi trabajo y te apetece invitarme a una cerveza presiona aqui

Nueva version con estas mejoras:
Que funciona:
Pantalla con multitouch
Sonido
Wifi
Control de brillo
GPS
Se /data/media se monta en /mnt/sdcard, sd real en /mnt/sdcard_ext
Camara (Ya funciona el video, pero graba muy lento)
Autorotacion
Aplicaciones de google (Market!!!!)
Bateria
Suspension
Bluetooth
Microfono
3G (ya funciona en todas las aplicaciones de Android, incluido el market, pero esta en fase alpha porque aun tiene algunos problemas… ver notas despues)
Fondo de pantalla (no funcionan todos, pero he añadido un Live que imita el agua que si que funciona, probad otros del market)
Youtube
No mas pantallas blancas en las aplicaciones, ya que por defecto ya esta marcado el tema de usar la GPU con 2D
Tambien he quitado el estupido borde rojo.
Añadido soporte para wifi Intel (no probado)

En cuanto al 3G, teneis que tener una tarjeta metida en el arranque de la tablet y que el proveedor este soportado (yo he probado con movistar y simyo y solo me ha funcionado movistar). Cuando la tablet arranque, esperais como 5 minutos os vais al Terminal emulator y ejecutais:
su
start pppd-gprs

Cuando ejecutais su la primera vez os sale la aplicacion superuser, teneis que decirle que permita usar su.
No os aseguro que funcione y no os voy a dar soporte, es solo una prueba de concepto…

En cuanto a las wifi intel, esto es una peticion de algun usuario que estan usando tablets iguales a la wetab, pero con wifi intel en vez de atheros… No esta probado para nada y no da ningun problema a los usuarios de wetab (bueno, la imagen es un poco mas grande).

Seguire intentando solucionar el tema del 3G, pero no espereis una solucion rapida porque ya no tengo el tiempo de antes. Si alguien quiere encargarse de ello le explico cual es el problema y las pruebas que tiene que hacer.

El resto de las cosas (suspension y demas sigue funcionando como la version anterior)

Link: Actualizado arriba

ACTUALIZACION3 (7-2-2012):

Siento la cagada con el fichero anterior, cuando uno toquetea y quiere mandarlo un viernes a ultima hora sin probarlo todo, esto es lo que pasa😦. Esta actualizacion esta mas probada, y su estado es:

Que funciona:
Pantalla con multitouch
Sonido
Wifi
Control de brillo
GPS
Se ha creado una SD virtual que esta en /data/media (como en algunos tablets sin sd real) y se monta en /mnt/sdcard, pero ademas se monta la sd real en /mnt/sdcard_ext
Camara (Ya funciona el video, pero graba muy lento)
Autorotacion
Aplicaciones de google (Market!!!!)
Bateria
Suspension
Bluetooth
Microfono

Que no funciona:
Fondo de pantalla
3G (estoy tratando de integrarlo completamente en android para que funcione automaticamente)

Suspension: Funciona correctamente, para volver a usar la tablet solo teneis que presionar 1 vez al boton trasero. 2 veces al boton trasero te mostrara el menu de apagar.

Bluetooth: Para que el BT funcione teneis que tener activada la wifi, es decir, al activar el BT siempre tener la wifi activada, si no no funcionara, una vez activado el BT se puede desactivar la wifi y seguira funcionando.

Si teneis una pantalla en blanco en las aplicaciones, recordad que hay que marcar en Desarrollo usar GPU para 2D.

Aqui teneis el link: ACTUALIZADO

—————————————————————-

Agradecimientos: Xyzzy del foro http://www.wetab-community.com y ejtagle de vega.mocado.com. Sin su trabajo esto no habria sido posible.

Corvus.

    • TitoPoli
    • 24/01/12

    Bravo, maestro!!!

    • Pepito
    • 25/01/12

    Estás hecho un artista !!

    • SpAiK
    • 26/01/12

    Hola Corvus, primero agradeceros el curre que os estáis pegando.

    No he podido testar la iso porque de nuevo no me instala, no pasa del formateo de la partición. Es curioso porque solo me ocurre con tus isos.

    • Pues sinceramente no se que puede pasar… esta mas que probada, y usa el mismo instalador que la version oficial. Has probado a usar otro pincho, o a no formatear la particion?

      Corvus

    • xabigoi
    • 26/01/12

    Funcionan el navegador, gmail y el market. Sigue sin funcionar los fondos de pantalla y la fake sd que he creado desde el instalador no va, el programa galería no la detecta. Por lo demás, y de momento, una gozada. Gracias y si necesitas algo
    coméntame…

    • Los fondos los mirare, pero estamos echando a andar el 3G (tiene buena pinta), y el resto del hardware antes que los bugs que nos de android (a no ser que mirando una cosa, nos demos cuenta de que hay una solucion rapida a otras).

      En cuanto al FakeSD, la verdad es que no lo he probado nunca… con una sd real funciona perfectamente, y no se como funciona una fake😦

    • Titopoli
    • 29/01/12

    Pues después de unos días probándolo, la verdad es que promete muchísimo y puede llevar la Wetab a otro nivel. Paso a comentar los problemas que me he encontrado:

    – No sincroniza el calendar de las cuentas Google que incorporo. Ni siquiera aparece entre los elementos para sincronizar.

    . En ocasiones deja de responder la pantalla táctil durante un instante. Esto no sé si es problema de la pantalla o de que se sature la memoria…

    – No puedo ver vídeos de Youtube. Ni en la aplicación ni en el navegador.

    Adelante, que está quedando muy chulo!!!!.

    • Gracias.

      El tema del calendario, en la proxima actualizacion lo soluciono (si no se me olvida :D).
      A mi la pantalla no se me queda bloquedada, puede ser que tengas una sd lenta o algo?
      No tenemos youtube porque funciona con flash y no hay paquetes de flash para x86 :(…y no creo que los haya…a ver si se ponen con HTML5 y tiramos flash a la basura.

      Corvus

    • SpAiK
    • 30/01/12

    Hola Corvus, sería posible que las actualizaciones se puedan aplicar sin tener que reinstalar todo el sistema cada vez? Con un paquete autoinstalable o de forma manual. Hice una prueba con la última actualización de HC de Wetab-Community, copiando los ficheros nuevos y borrando la caché y Dalvik (tal y como se suele hacer en las roms de móviles) y funcionó.

    Sobre lo de Youtube, la app no se supone que funciona aparte sin necesidad de Flash? En HC así funciona.

    En cualquier caso estáis haciendo un trabajo genial!

    • Si, el tema de las actualizaciones funciona igual, en principio, dejando la carpera /data sin tocar, si sustituyes la carpera system, y el fichero kernel (si ha cambiado) y despues borras la cache y la dalvik todo deberia de funcionar (SOLO USUARIOS EXPERIMENTADOS).

      Hay un puñado de aplicaciones de youtube, las dos que yo he probado usaban flash, pero no se si alguna de las otras no… lo mirare en la proxima actualizacion.

      Corvus.

    • Titopoli
    • 31/01/12

    corvusmod :
    Gracias.
    El tema del calendario, en la proxima actualizacion lo soluciono (si no se me olvida ).
    A mi la pantalla no se me queda bloquedada, puede ser que tengas una sd lenta o algo?
    No tenemos youtube porque funciona con flash y no hay paquetes de flash para x86 …y no creo que los haya…a ver si se ponen con HTML5 y tiramos flash a la basura.
    Corvus

    No sabía que la sd podía provocar eso. Pero la he cambiado por una Kingston y sigue sucediendo. Lo noto sobretodo en el navegador de Internet, gmail o gtalk. No es que se bloquee (el cursor sigue parpadeando), pero la táctil no responde.

    Reinstalaré, porque al principio no sucedía…

    Saludos.

  1. Saludos

    Muchas gracias por el trabajo que estas haciendo…. me parece genial….

    aunque me gustaria poder disfrutarlo mejor…. y es que solo lo puedo probar bien desde la opcion live…. no hay manera de poder instalarlo…. a no ser que formatees y asi y todo no tengo suerte ya que cuando termina la instalacion si le doy a run android entonces inicia (instalado e una usb formateada a ext3) pero si reinicia el tablet no hay manera de despertar por el android😦 es como si el grub pasara de mi y no se guardaran los cambios.

    buen dia

    • Busca en la web de forotablets el manual de como configurar el grub para esto…

      Corvus

        • Daniel
        • 14/03/12

        Hola,

        a mi me pasaba lo mismo y lo solucioné borrando las particiones y volviendolas a crear.
        Con el programa de instalación no podia borrarlas así que lo hice arrancando con un Live de Ubuntu y borrándolas.

    • SpAiK
    • 11/02/12

    Hola Corvus, la última versión funciona genial, mi enhorabuena y agradecimiento por el trabajo que te estás pegando.

    Sobre lo de Youtube, supongo que de HC a ICS algo habrá cambiado profundamente en el código para que ahora no se puedan reproducir los videos desde la propia aplicación. De todas formas he leído un post de alguien que parece haber encontrado una solución. Te dejo el enlace y espero que te sirva de algo:

    http://groups.google.com/group/android-x86/browse_thread/thread/5b57ca4ab3657d7c

    • Si, ya lo habia visto, gracias. Tambien creo que uedo arreglar el 3g. Durante la semana que viene intentare sacar una version nueva.

      Corvus

  2. Me pasa algo raro….

    al final cree una particion exclusiva para tu genial rom… PERO!!!!

    Ahora cuando termino de instalar le digo Run Android

    y todo de maravillas

    el problema es cuando reinicion me sale el grub, me empieza a cargar el sistema veo la imagen de android cargando…. pero se queda en esa pantalla infinitamente….

    Como podria solucionar el problema o al menos ver cual es?

    Saludos y muchas gracias por tu trabajo

    • Which Android image? the little white one or the big one?

      Corvus

    • Lo siento, a veces se me va la pinza con el español-ingles… que imagen, la pequeña blanca que dice ANDROID: o la que sale despues en “bonito”?

      Corvus

      • la imagen que salen en el centro que dice android y tiene una animacion…..

      • y estoy usando el ISO wetab.iso·Download (153.0 MB) pq pesa mas megas xDDD

      • ahh y mi tablet no tiene 3g, tiene 2gb de ram y 64ssd…. no es un wetab de la pagina de wetab, segun intel es el mismo hardware pero mas ram y disco

      • una cosilla…. donde esta el grub? el que encuentro no tiene nada que ver con el que bootea :((((

      • yeradis (@yeradis) :

        y estoy usando el ISO wetab.iso·Download (153.0 MB) pq pesa mas megas xDDD

        Creo que esa no es la ultima, pero no estoy seguro… mira el ultimo link publicado.

        En cuanto al grub, pues depende de lo que tengas instalado, si tienes un linux, entra y monta la particion donde tienes android (sda6, por ejemplo) y alli tendras el grub que arranca.

        Estas seguro que el hardware es el mismo? si entras en un linux ejecuta lspci y lsusb o lshal si tienes este comando y ponlo en http://www.pastebin.com y lo comparo con una wetab.

      • nada ya vi donde estaba el grub

        con:

        #fdisk -l /dev/block/sda
        this should tell you which partitions have linux and windows. Replace sda with another drive if applicable.
        #cd /data
        #mkdir tmpmnt
        #mount -t ext3 /dev/block/sda1 tmpmnt
        change the above to reflect the correct parition and FS type.
        #cd tmpmnt/grub
        #vi menu.lst
        Change grub configuration
        #cd /data
        #umount tmpmnt

        y alli veo una linea que dice androidboot.hardware=wetab

        es a eso a lo que te referias cuando me decias de revisar el grub o me falta algo mas¿

      • ahora ejecutare esos comandos pero el hardware es este http://www.exopc.com/devices/

        y creo que ya vi cual es el problema…

        resulta que en windows tengo en C las otras instalaciones de android-x86 las cuales ya no las necesito pero la funcion que dice Detecting Android busca primero en las otras particiones antes de buscar en la particion que hace el boot que en este caso es la ext3 donde instale tu rom…. voy a probar a cargarme todas las carpetas de grub y android de la particion de windows a ver si entra a la sda3 que es donde esta tu rom… no se pq no busca primero por la particion que hace el boot

      • hmmm el problema era ese…. la accion Detecting Android buscaba antes en las otras particiones cuando deberia empezar por la que hace Boot en mi caso la particion donde tengo instalada tu rom… pero estaba buscando en las otras donde antes tenia otras roms…. las borre y ahora ha entrado en la tuya

        en cuanto a la ultima version cual es la ultima la que dice RC1 publicada el 7 del 2?

        es que mas abajo hay otra y esa es la que se llama wetab.iso y pesa mas de 150 megas las del 7 del 2 dice algo de RC1 y pesa unos 135 megas

  3. cierto la wetab.iso no era la ultima ya que dice que es de hace 20 dias y la RC1 es de hace 9 dias …. hmmm nada a instalar nuevamente xD

    MUCHAS GRACIAS CRACK

    • Abel
    • 20/02/12

    hola corvusmod. Gracias por tu blog y tu trabajo. Acabo de probar tu compilación y va bastante bien. Aprovecho para hacerte una pregunta y si quieres me respondes. Es posible instalar app desde la tarjeta sd (ya sea la virtual o la real)??? Ya sabes, app bajadas no desde market. Es que lo he intentado y no me sale, me dice que la app no está instalada.

    Gracias y un saludo!

    • Tienes que marcar origenes desconocidos y tener una apk que sea compatible.

        • Abel
        • 14/03/12

        Gracias corvus, muchas gracias. Si lo había hecho, el problema era q la apk está hecha para una versión anterior. De nuevo muchas gracias por tú trabajo!

    • TitoPoli
    • 15/03/12

    Qué bien que vuelva a funcionar YouTube. Cada vez tiene mejor pinta.

    Una cosa, ahora al darle al botón de encendido/apagado, no sale la ventana para apagar, sino que se bloquea la pantalla. ¿Qué hay que hacer ahora para apagar la tablet?

    Gracias!

    • Darle dos veces al boton y saldra el menu de apagar.

        • TitoPoli
        • 15/03/12

        Jeje Así de fácil. Gracias!!

    • TitoPoli
    • 15/04/12

    Hola Corvus,

    No sé si ya lo has explicado, pero no lo he encontrado. ¿Cómo se debería particionar el disco para instalar sólo Android? Y, de paso, ¿se puede hacer que la sd virtual sea de más de 2Gb y así aprovechar los 32Gb que tiene el dispositivo?

    Muchas gracias,
    TitoPoli

  4. Con una sola particion ext3 es sufuciente, en ella instalaria tanto android como grub (el gestor de arranque).

    En las nuevas versiones la sd virtual tiene el tamaño que queda libre en la particion donde esta instalado android, es decir, yo tengo una particion de 2G, android me ocupa 500mb (por ejemplo) y cuando entro en settings, almacenamiento, me dice que mi sd es de 1’5 gb.

    Corvus.

      • TitoPoli
      • 21/04/12

      Muchas gracias, Corvus.

      La verdad es que el sistema ha quedado muy chulo. Lo tengo instalado en una partición de 25Gb y es del todo funcional, sin necesidad de tener una sd conectada. Sigo teniendo el problema de falta de respuesta en algunas ocasiones, pero tengo que descubrir el motivo, porque en otras, va superfluido. Está recién instalado y casi sin software adicional, osea que no creo que sea cosa de ningún programa puñetero…. en fin, nada relevante.

      Seguiré tu bloc con interés, para cualquier novedad en éste u otro tema.

      Un saludo,
      TitoPoli

      • Gracias. Si tienes localizado en que momento se queda pillado, puedes arrancar catlog y ver el fallo. O enviarmelo y le echo un vistazo…

    • josevi
    • 23/05/12

    hola corvus e seguido todos tus pasos y e intalado android y funciona perfectamente todo menos el 3g uso una tarjeta de movistar, el problema es que me compre esta tablet para darle uso desde exteriores y por esto necesito 3g para todo me gustaria saber si puedes mirarlo y meter una pequeña actualizacion para que funcione, gracias.
    Un saludo.

    • Siento decirte que ahora mismo el proyecto con la wetab esta parado, ya que estoy con otras cosas. Intenta instalarte la ultima version de android x86 (la de tegav2) y deberia de funcionar el 3G

    • Abel
    • 22/07/12

    Hola, sabéis si se pueden hacer llamadas con la SIM metida. Es que no me deja… Gracias

    • Hanzony Silva
    • 10/10/12

    Saludos!
    Tengo una wetab y le instalé el android 4 que publicaste y funciona muy bien! solo tengo dos problemas y queria saber si me puedes ayudar, la sim card me la detecta, recibe y envia sms y llamadas pero no establece la conexión a internet! tengo que configura el vpn?? el apn lo detecta y establece la configuración de movilnet (operadora de Venezuela), por supuesto tengo un plan de datos en mi linea. el otro problema es con el micrófono que no funciona y cuando medio funciona graba en muy mala calidad!
    En lo que puedas ayudarme te lo sabre agradecer y compensar!

    • En cuanto al apn no se que decirte, la verdad es que yo hice una prueba rapida con una linea que me prestaron y no hice mas pruebas. Intenta mirar en http://www.wetab-community.com usando el traductor de google (a no ser que sepas aleman) a ver si alguien ha solucionado el problema. En cuanto al micro, si, es un fallo reconocido, pero en estos momentos le estoy dedicando mi escaso tiempo a otros dispositivos y no puedo dedicarselo a la wetab. Si en algun momento lo hago, subire la rom resultante en este blog. Siento no poderte ayudar mas, pero ando escaso de tiempo….

  5. Hola Corvus, entiendo que haz dejado de usar la wetab, pero este es un caso que necesita de su ayuda y experiencia.. Mi wetab tenia su soft original, buscando en inernet y con sus tutoriales logre tratar de instalarle android, cometi algun error y el asunto es que cuando enciendo la tablet, llega hasta el menu azul del grub y cuando selecciono un opcion, me dice que no encuentra los archivos en una pantalla negra… No logro hacerlo bootear desde USB ni nada, puesto que enseguida se va al grub y se repite la historia. Por favor ayuda. Saludos desde colombia

    • Siento no poder ayudarte mas, pero yo lo que haria seria ir al foro http://www.forotablets.com y preguntar alli, que tienen un apartado de wetab. De todas formas, por lo que me comentas parece ser un problema de que grub no esta bien configurado. Puedes buscar en google el fallo que te da, ya que la wetab es como un pc y ese fallo puede ser facil de solucionar.

  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: